EIGRPの特徴

名前付き設定(NAMED mode) について

router eigrp MULTI-AF
 address-family ipv4 unicast autonomous-system 100
  topology base
  exit-af-topology
 network 150.1.0.0
 network 155.1.0.0
exit-address-family

redistribute は topology base 配下で投入する
R6(config)#router eigrp MULTI-AF
R6(config-router)#address-family ipv4 unicast autonomous-system 100
R6(config-router-af)#topology base
R6(config-router-af-topology)#redistribute connected route-map CONNECTED_to_EIGRP
summary-address は af-interface モードで設定する
R6(config-router-af)#af-interface Et0/1.146
R6(config-router-af-interface)#summary-address 6.0.0.0 255.255.252.0
%DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 155.1.146.1 (Ethernet0/1.146) is resync: summary configured

address-family ipv4 unicast autonomous-system 100

unicast を省略し設定すると unicast が自動的に入る。

経路集約の設定

interface mode で設定する
&color(,#a3e0fd){R4(config)#interface tunnel 0}
&color(,#a3e0fd){R4(config-if)#ip summary-address ?}
&color(,#a3e0fd){ eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)}
&color(,#a3e0fd){ rip Routing Information Protocol (RIP)}
&color(,#a3e0fd){R4(config-if)#ip summary-address eigrp 100 4.0.0.0 255.255.252.0}
&color(,#a3e0fd){%DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 155.1.0.5 (Tunnel0) is resync: summary configured}
&color(,#a3e0fd){}
どの interface に設定するかは、show ip eigrp neighbor で確認
&color(,#b3e2be){R6#show ip eigrp neighbors}
&color(,#b3e2be){EIGRP-IPv4 VR(MULTI-AF) Address-Family Neighbors for AS(100)}
&color(,#b3e2be){H Address Interface Hold Uptime SRTT RTO Q Seq}
&color(,#b3e2be){ (sec) (ms) Cnt Num}
&color(,#b3e2be){1 155.1.67.7 Et0/1.67 11 00:31:21 7 100 0 56}
&color(,#b3e2be){0 155.1.146.1 Et0/1.146 11 00:32:08 10 100 0 }

デフォルトルートで経路集約

classic EIGRP

interfaceモードで設定する

interface Tunnel0
ip summary-address eigrp 100 0.0.0.0 0.0.0.0

NAMED EIGRP

router eigrp 配下で設定する

router eigrp MULTI-AF
address-family ipv4 unicast autonomous-system 200
af-interface Ethernet0/1.67
summary-address 0.0.0.0 0.0.0.0

LEAK-MAP

leak = 漏らす
leak-map : summary-address のオプション
サマリルートの中から、特定のルーティング情報を集約対象外として広告する手段。
対象はroute-mapで指定する
ルーティング情報=プレフィックス であることから、マッチングルールは prefix-list で作成すべき。

interface Tunnel0
 ip summary-address eigrp 100 0.0.0.0 0.0.0.0 leak-map LEAK_LOOPBACK40
route-map LEAK_LOOPBACK40 permit 10
 match ip address prefix-list LOOPBACK40
ip prefix-list LOOPBACK40 seq 5 permit 4.0.0.0/24

メトリックの計算方法

コストロードバランシング

メモ

CCO


Seesaa Wiki関連リンク